Engineering
Releases
News and Events

Early Access: SpringSource Tool Suite for Eclipse Indigo (3.7)

The Eclipse Indigo (3.7) M6a packages are available for download from Eclipse since a few days, so its time for us to allow you to use the SpringSource Tool Suite (STS) on top of that milestone version. :-)

Its just an early access version of STS, but we managed to get all the pieces together for Eclipse 3.7: An AJDT version for Eclipse 3.7, a Groovy-Eclipse version that runs of 3.7 and the SpringSource Tool Suite itself, of course, containing Spring IDE, Grails tooling and all the other nice features you know from STS - all now also running on top of the latest Eclipse Indigo milestones.

How to install



The necessary dependencies for STS are all available from the composite update site: http://dist.springsource.com/snapshot/TOOLS/composite/e3.7, if you wanna add something manually.

We also included the installation instructions for 3.7 in the “Installing from the Nightly Snapshot Update Site” section of the installation instructions for STS.

Manual Installation


Here are the individual update sites from which you can install STS, AJDT and Groovy-Eclipse for Indigo (3.7):


Feedback


This is an early access version of STS that is continually updated. If you observe problems running STS on top of your Eclipse Indigo (3.7) M6a (or later) installation, please let us know and report issues to: https://issuetracker.springsource.com/browse/STS.

Enjoy!

comments powered by Disqus