Spring Boot 1.x EOL Aug 1st 2019

News | Phil Webb | July 30, 2018 | ...

All good things must come to an end, and for the 1.x line of Spring Boot that means we will need to cease maintenance twelve months from today, on Aug 1st 2019.

We will keep publishing occasional 1.5.x maintenance releases up until that point and will then end the branch.

Existing Spring Boot 1.x users should plan accordingly to ensure that they have upgraded to the latest 2.x version before that date. Please also note that Spring Boot 2.0 and above requires Java 8+, so if you're running Java 6 or 7 you should also plan on upgrading your JDK.

For detailed instructions on what you'll need to do to upgrade a Spring Boot 1.5 application to 2.0, check out the migration guide.

Good luck!

Get the Spring newsletter

Thank you!

Get ahead

VMware offers training and certification to turbo-charge your progress.

Learn more

Get support

Spring Runtime offers support and binaries for OpenJDK™, Spring, and Apache Tomcat® in one simple subscription.

Learn more

Upcoming events

Check out all the upcoming events in the Spring community.

View all