Spring Security Advisories

CVE-2013-6430 Possible XSS when using Spring MVC

LOW | JANUARY 14, 2014 | CVE-2013-6430


The JavaScriptUtils.javaScriptEscape() method did not escape all characters that are sensitive within either a JS single quoted string, JS double quoted string, or HTML script data context. In most cases this will result in an unexploitable parse error but in some cases it could result in an XSS vulnerability.

Affected Spring Products and Versions

  • Spring MVC 3.0.0 to 3.2.1
  • Earlier unsupported versions may be affected


Users of affected versions should apply the following mitigation:

  • Users of 3.x should upgrade to 3.2.2 or later


This issue was originally reported to the Spring Framework developers by Jon Passki and the security implications brough to the attention of the Pivotal security team by Arun Neelicattu.


  • 2014-Jan-14: Initial vulnerability report published.

Get ahead

VMware offers training and certification to turbo-charge your progress.

Learn more

Get support

Tanzu Spring offers support and binaries for OpenJDK™, Spring, and Apache Tomcat® in one simple subscription.

Learn more

Upcoming events

Check out all the upcoming events in the Spring community.

View all