Skip to main content

Spring Security Advisories

CVE-2014-1904 XSS when using Spring MVC

MEDIUM | MARCH 11, 2014 | CVE-2014-1904


When a programmer does not specify the action on the Spring form, Spring automatically populates the action field with the requested uri. An attacker can use this to inject malicious content into the form.

Affected Spring Products and Versions

  • Spring MVC 3.0.0 to 3.2.7
  • Spring MVC 4.0.0 to 4.0.1
  • Earlier unsupported versions may be affected


Users of affected versions should apply the following mitigation:

  • Users of 3.x should upgrade to 3.2.8 or later
  • Users of 4.x should upgrade to 4.0.2 or later


This issue was discovered and reported responsibly to the Pivotal security team by Paul Wowk of CAaNES LLC.


  • 2014-Mar-11: Initial vulnerability report published.
  • 2014-Aug-19: Correct affected versions to exclude Spring MVC 3.2.8 and include a reference to the 3.2.x commit.

Get ahead

VMware offers training and certification to turbo-charge your progress.

Learn more

Get support

Spring Runtime offers support and binaries for OpenJDK™, Spring, and Apache Tomcat® in one simple subscription.

Learn more

Upcoming events

Check out all the upcoming events in the Spring community.

View all

© 2023 VMware, Inc. or its affiliates. Terms of Use PrivacyTrademark Guidelines Your California Privacy Rights Cookie Settings

Apache®, Apache Tomcat®, Apache Kafka®, Apache Cassandra™, and Apache Geode™ are trademarks or registered trademarks of the Apache Software Foundation in the United States and/or other countries. Java™, Java™ SE, Java™ EE, and OpenJDK™ are trademarks of Oracle and/or its affiliates. Kubernetes® is a registered trademark of the Linux Foundation in the United States and other countries. Linux® is the registered trademark of Linus Torvalds in the United States and other countries. Windows® and Microsoft® Azure are registered trademarks of Microsoft Corporation. “AWS” and “Amazon Web Services” are trademarks or registered trademarks of Inc. or its affiliates. All other trademarks and copyrights are property of their respective owners and are only mentioned for informative purposes. Other names may be trademarks of their respective owners.