Spring Security Advisories

CVE-2019-3778: Open Redirector in spring-security-oauth2

CRITICAL | FEBRUARY 21, 2019 | CVE-2019-3778


Spring Security OAuth, versions 2.3 prior to 2.3.5, and 2.2 prior to 2.2.4, and 2.1 prior to 2.1.4, and 2.0 prior to 2.0.17, and older unsupported versions could be susceptible to an open redirector attack that can leak an authorization code. A malicious user or attacker can craft a request to the authorization endpoint using the authorization code grant type, and specify a manipulated redirection URI via the "redirect_uri" parameter. This can cause the authorization server to redirect the resource owner user-agent to a URI under the control of the attacker with the leaked authorization code.

This vulnerability exposes applications that meet all of the following requirements:

  • Act in the role of an Authorization Server (e.g. @EnableAuthorizationServer)
  • Uses the DefaultRedirectResolver in the AuthorizationEndpoint

This vulnerability does not expose applications that:

  • Act in the role of an Authorization Server and uses a different RedirectResolver implementation other than DefaultRedirectResolver
  • Act in the role of a Resource Server only (e.g. @EnableResourceServer)
  • Act in the role of a Client only (e.g. @EnableOAuthClient)

Affected Spring Products and Versions

  • Spring Security OAuth 2.3 to 2.3.4
  • Spring Security OAuth 2.2 to 2.2.3
  • Spring Security OAuth 2.1 to 2.1.3
  • Spring Security OAuth 2.0 to 2.0.16
  • Older unsupported versions are also affected


Users of affected versions should apply the following mitigation:

  • <strong>2.3.x</strong> users should upgrade to <strong>2.3.5</strong>
  • <strong>2.2.x</strong> users should upgrade to <strong>2.2.4</strong>
  • <strong>2.1.x</strong> users should upgrade to <strong>2.1.4</strong>
  • <strong>2.0.x</strong> users should upgrade to <strong>2.0.17</strong>
  • Older versions should upgrade to a supported branch

There are no other mitigation steps necessary.

For users of Spring Boot 1.5.x and Spring IO Platform Cairo, it is highly recommended to override the spring-security-oauth version to the latest version containing the patch for the CVE. In order to override the version, you need to declare/set the property spring-security-oauth.version.

Below are instructions for users of Spring Boot 1.5.x.

To override a property using Maven, declare the property in your pom’s section:


To override a property using Gradle, configure the value in your build.gradle script:

ext['spring-security-oauth.version'] = '2.0.17.RELEASE'

Or in gradle.properties:


NOTE: The same instructions apply for users of Spring IO Platform Cairo. However, the version to specify is 2.2.4.RELEASE.


This issue was identified and responsibly reported by Dirk Koehler (github.com/phrinx) from dotloop. Special thanks to Macchinetta Framework Development Team from NTT, NTT Comware, NTT DATA Corporation for helping to verify the solution and identifying additional ways to exploit the vulnerability.



  • 2019-02-21: Initial vulnerability report published.

Get ahead

VMware offers training and certification to turbo-charge your progress.

Learn more

Get support

Spring Runtime offers support and binaries for OpenJDK™, Spring, and Apache Tomcat® in one simple subscription.

Learn more

Upcoming events

Check out all the upcoming events in the Spring community.

View all