VMware offers training and certification to turbo-charge your progress.Learn more
In Spring Boot versions 3.0.0 - 3.0.5, 2.7.0 - 2.7.10, 2.6.0 - 2.6.14, 2.5.0 - 2.5.14 and older unsupported versions, an application that is deployed to Cloud Foundry could be susceptible to a security bypass.
Specifically, an application is vulnerable when all of the following are true:
/cloudfoundryapplication/**. Typically, this will be if there is a catch-all request mapping which matches
NOTE: Applications using Spring Cloud Config Server can handle requests to
/cloudfoundryapplication/** by default and can be vulnerable if deployed to Cloud Foundry.
An application is not vulnerable if any of the following is true:
Users of affected versions should apply the following mitigation: 3.0.x users should upgrade to 3.0.6+. 2.7.x users should upgrade to 2.7.11+. 2.6.x users should upgrade to 2.6.15+. 2.5.x users should upgrade to 2.5.15+. Users of older, unsupported versions should upgrade to 3.0.6+ or 2.7.11+.
Workarounds: Disable Cloud Foundry actuator endpoints by setting
The VMware Security Response team provides a single point of contact for the reporting of security vulnerabilities in VMware Tanzu products and coordinates the process of investigating any reported vulnerabilities.
To report a security vulnerability in a VMware service or product please refer to the VMware Security Response Policy.